ForensiT Homepage
Forum Home Forum Home > ForensiT Support > Desktop Management
  Active Topics Active Topics
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

Default Profile on the Network

 Post Reply Post Reply
Author
Message
  Topic Search Topic Search  Topic Options Topic Options
redrice View Drop Down
Newbie
Newbie


Joined: 19 May 2016
Online Status: Offline
Posts: 5
  Quote redrice Quote  Post ReplyReply Direct Link To This Post Topic: Default Profile on the Network
    Posted: 25 May 2016 at 12:49pm
Defprof has worked great for me, when I figured out how to actually do it right. I use it on Windows 10, and I want to create a customized default profile so every user that logs into a computer can have taskbar icons for chrome, outlook, etc.

It has all worked fine locally on my test machine, but then I made the local default profile into a network default profile. I used the "copy to..." button to copy the Default folder in "C:\Users" to "\\domain\netlogon\Default User.v5". However, the network default profile had issues that my local one did not have. The two problematic changes are that I can click on cortana/windows search bar but nothing happens, and opening the start menu has a one second delay. A one second delay doesn't sound bad, but it is. A less problematic change is the tiles for the start menu. Almost all of them are present, but on the local default profile only had a couple tiles in the start menu were there.

The last part with the tiles just shows that Windows is changing things automatically, and this is most likely the reason for all of the changes. A problem could also be the network default profile only contains the roaming folder, I don't know what implications that may have though.

Any ideas on why my network default profile has problems when my local one does not?
Back to Top
redrice View Drop Down
Newbie
Newbie


Joined: 19 May 2016
Online Status: Offline
Posts: 5
  Quote redrice Quote  Post ReplyReply Direct Link To This Post Posted: 07 Jun 2016 at 1:53pm
I figured it out. It was not a Defprof issue, it was a permissions issue. I needed to add Authenticated Users and ALL APPLICATION PACKAGES to the permissions of the Default Profile after I copied it into the netlogon folder.

To do so, perform the following:

1. Run "regedit"
2. Select "HKEY_USERS"
3. Click File, then Load Hive...
4. Navigate to \\domainname\netlogon\Default User.v5 (or whatever .vx you have)
5. Type ntuser.dat in the name section and hit Enter
6. Type Default Profile (or whatever you want) and hit enter
7. Right click on the Default Profile folder (or whatever you named it)
8. Select Permissions...
9. Add Authenticated Users which is a standard domain permission and add ALL APPLICATION PACKAGES which is a local permission, so location will have to be set to local machine for this one
10. Set both to full control
11. Select the Default Profile folder (or whatever you named it)
12. Click File, then Unload Hive...

Aaaaand, you're done!
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.