ForensiT Homepage
Forum Home Forum Home > ForensiT Support > Domain Migration
  Active Topics Active Topics
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

My Documents do not change

 Post Reply Post Reply
Author
Message
  Topic Search Topic Search  Topic Options Topic Options
HAGO View Drop Down
Newbie
Newbie


Joined: 23 Feb 2007
Location: Netherlands
Online Status: Offline
Posts: 1
  Quote HAGO Quote  Post ReplyReply Direct Link To This Post Topic: My Documents do not change
    Posted: 23 Feb 2007 at 3:10pm
Hi,
 
In the source domain we have a mix of users with roaming profiles (desktops) and local profiles (laptops). Whenever a user has a laptop the My Document folder is always syncronised with the cached folder on the network (\\servername\first.lastname$\cached\My Documents). Originally this location is set by the account in AD from the specific user if the profile path field is entered right. 
 
If profile wizzard migrates this specific user to another domain this location is still present, even if the profile path is different in the new domain. The result is that the users is prompted for a username / password for mapping the old location.
 
- Can this behavior be changed? We would like to map to the new cached folder instead?
- Can we somehowe make use of locally synchronised data in the mydocuments?
 
Any comments are welcome!
Back to Top
Support View Drop Down
Moderator Group
Moderator Group


Joined: 09 Nov 2006
Location: United Kingdom
Online Status: Offline
Posts: 1335
  Quote Support Quote  Post ReplyReply Direct Link To This Post Posted: 26 Feb 2007 at 3:07pm

Hi,

User Profile Wizard does not attempt to change folder redirection settings when migrating a user to a new domain.

Assuming that you have set up the redirection of the folder in AD via a Group Policy, by far the easiest thing to do is remove the policy prior to the migration. (One option would be to create a new "Migration" OU with the new GPO and move your users to it.)

To create the policy, go to "User Configuration\Windows Settings\Folder Redirection\My Documents" in the Group Policy Object Editor, and change the "Target" setting to "Basic - Redirect everyone's folder to the same location." You can then change the Target Folder Location to "Redirect to the local userprofile location."

Important! You must also change the "Policy Removal" setting on the "Settings" tab to "Redirect the folder back to the local userprofile location when policy is removed." If you don't do this, the user's data will stay on the server! Not only that, if you do not set the folder back to a local "My Documents" folder, the new domain will try to redirect the old domain server folder - which won't work.

If you don't reset the policy, you will have to copy the "My Documents" data locally before the machine joins the new domain, maybe via a script, and then change the "Personal" string value in the registry under HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders back to "%userprofile%\My Documents". You should just be able to create a "My Documents" folder in C:\Documents and Settings\Username.

We can't really use the locally synchronised data, as this held kept in a cache typically under C:\Windows\CSC.



Edited by Support - 16 Feb 2009 at 11:22am
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.016 seconds.