ForensiT Homepage
Forum Home Forum Home > ForensiT Support > Domain Migration
  Active Topics Active Topics RSS Feed: Outlook not working after migration
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

Outlook not working after migration

 Post Reply Post Reply Page  <12
Author
Message
  Topic Search Topic Search  Topic Options Topic Options
medicaustik View Drop Down
Newbie
Newbie


Joined: 09 Jul 2018
Online Status: Offline
Posts: 1
  Quote medicaustik Quote  Post ReplyReply Direct Link To This Post Posted: 09 Jul 2018 at 12:41pm
Originally posted by JohnMSP

Spent ages with this one as part of an Azure AD cloud only to Azure AD / AD hybrid setup.

Disabling ADAL wasn't an option as we use MFA.

We found it wasn't just Outlook broken - none of the Office 365 apps could sign in either.

Ultimately I found the issue: there's a token that needs resetting in the user profile directory.

Rename the folder that starts "Microsoft.AAD.BrokerPlugin" in %appdata%\local\packages\ to something else (you will need to be logged in as another user to do this) and then log out, then in as the user. You should find Outlook and other Office apps now work as expected.

Hope this helps someone - spent an age troubleshooting this one!


John buddy, you're a hero.

This solution worked for me.

Disabling ADAL is not an option in environments that require MFA.
Back to Top
bevege View Drop Down
Newbie
Newbie


Joined: 27 Jul 2018
Online Status: Offline
Posts: 2
  Quote bevege Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2018 at 11:49pm
Originally posted by Support

In most cases, this problem can be avoided if you sign-out of Office 365 before migrating the profile.


Any ideas how to permanently logout of office apps? When I go into each individual app (excel, word, outlook) it lets me logout but when I open the app again I'm still logged. I tried logging out of each app and then doing the migration outlook doesn't work. All the other apps are fine. Disabling ADAL fixes the issue but who knows what it may break in the future. Creating a new profile doesn't work either.

Any ideas?

Edited by bevege - 27 Jul 2018 at 11:56pm
Back to Top
PerryW View Drop Down
Newbie
Newbie


Joined: 02 Aug 2018
Location: UK
Online Status: Offline
Posts: 1
  Quote PerryW Quote  Post ReplyReply Direct Link To This Post Posted: 02 Aug 2018 at 6:07am
John,

Not sure what I am doing wrong but this is not working for me, I renamed that folder and logged back in and I could see that I was signed in but as soon as I tried to connect to OneDrive/SharePoint it asked for credentials and then the password box vanished again.

Am I missing something, I've tried removing all credentials in credential manager but to no avail.

Cheers Perry
Back to Top
jkaufman View Drop Down
Newbie
Newbie


Joined: 03 Aug 2018
Online Status: Offline
Posts: 1
  Quote jkaufman Quote  Post ReplyReply Direct Link To This Post Posted: 03 Aug 2018 at 5:58pm
I am having the same issue
Back to Top
bevege View Drop Down
Newbie
Newbie


Joined: 27 Jul 2018
Online Status: Offline
Posts: 2
  Quote bevege Quote  Post ReplyReply Direct Link To This Post Posted: 23 Aug 2018 at 2:30pm
So I finally figured this out. Such a PITA. The reason I couldn't log out of any office app had to do with a previously unknown O365 install. I noticed that none of the New O365 installs were registering on the O365 portal. IE, when I looked at the "Office Installs" for each user they said no installations or whatever. It was odd because they appeared to activate but it said no installations.

This article explains how to fix the problem.

I only had to do steps 1 and 3. I did not do anything in the registry. After all this I could then log out and stay logged out of all Office apps. I did a manual migration and it worked as expected. I also confirmed with Microsoft that this is the recommended method to fix the issue. Didn't want to break anything else.

Now I need to figure out how to map the local profile names to new domain profile names while doing an scripted migration.  I tried but it wasn't working.

Hopefully this will help someone.
Back to Top
bowlofpixels View Drop Down
Newbie
Newbie


Joined: 02 Oct 2018
Online Status: Offline
Posts: 1
  Quote bowlofpixels Quote  Post ReplyReply Direct Link To This Post Posted: 02 Oct 2018 at 1:25pm
Having the same issues. New profile works fine. Ran Office manual uninstall tool and reinstalled, cleared keys via ospp.vbs file. We don't show an ADAL registry entry. This is a huge issue as we have 100+ users that will need to be migrated. Get it together Microsoft!
Back to Top
BigBlue05 View Drop Down
Newbie
Newbie


Joined: 04 Oct 2018
Online Status: Offline
Posts: 1
  Quote BigBlue05 Quote  Post ReplyReply Direct Link To This Post Posted: 04 Oct 2018 at 9:15pm
JohnMSP, you are a genius! I was banging my head against this one for hours.

Huge help.

Thank you very much.

Edited by BigBlue05 - 04 Oct 2018 at 9:17pm
Back to Top
 Post Reply Post Reply Page  <12

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.014 seconds.