ForensiT Homepage
Forum Home Forum Home > ForensiT Support > Move Computer
  Active Topics Active Topics
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

Transwiz Transfer_All script stops at 25

 Post Reply Post Reply
Author
Message
  Topic Search Topic Search  Topic Options Topic Options
cio-john View Drop Down
Newbie
Newbie


Joined: 18 May 2019
Online Status: Offline
Posts: 3
  Quote cio-john Quote  Post ReplyReply Direct Link To This Post Topic: Transwiz Transfer_All script stops at 25
    Posted: 18 May 2019 at 10:19pm
I have about 100 users I am trying to transfer and I get a few strange things happening.
  • Not sure how it is picking what profiles to start with but it seems a bit random
  • I added several to the exclusion list and it included them anyway
  • It is is only migrating 25 then says backup complete, I thought I had used an eval license but I went back and downloaded my purchased one again (which by the way randomly generates a new key each download)

They are part of a domain. I tried removing the domain name and leaving strDomain="" but it just error-ed.
Any advice would be appreciated.

Thank you.
Back to Top
cio-john View Drop Down
Newbie
Newbie


Joined: 18 May 2019
Online Status: Offline
Posts: 3
  Quote cio-john Quote  Post ReplyReply Direct Link To This Post Posted: 18 May 2019 at 10:21pm
By the way my migration is tonight/tomorrow morning.
Back to Top
cio-john View Drop Down
Newbie
Newbie


Joined: 18 May 2019
Online Status: Offline
Posts: 3
  Quote cio-john Quote  Post ReplyReply Direct Link To This Post Posted: 18 May 2019 at 11:07pm
I ran the script in debug mode which was kinda helpful.
25 isn't a machine number, the script crashes. Error is listed.
Also included is a screenshot of the random order. If I know what profile was next what it was about to try to copy I could exclude that profile but it isn't going in alpha order.
See Screenshots here: https://imgur.com/a/mf5v6Be
Back to Top
Support View Drop Down
Moderator Group
Moderator Group


Joined: 09 Nov 2006
Location: United Kingdom
Online Status: Offline
Posts: 1311
  Quote Support Quote  Post ReplyReply Direct Link To This Post Posted: 19 May 2019 at 10:27am
There is nothing random here. The script is enumerating the profiles as they are listed in the registry.

The profiles are listed by SID. The script is stopping because one of the SID subkeys does not resolve to a valid SID. To fix it, you just have to add the line "On Error Resume Next" to the script:

For Each strSubkey In arrSubKeys

    On Error Resume Next
    Set objWmiSID = objWmiService.Get("Win32_SID.SID='" & strSubkey & "'")
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.015 seconds.