ForensiT Homepage
Forum Home Forum Home > ForensiT Support > Domain Migration
  Active Topics Active Topics
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

Error 2 Problem

 Post Reply Post Reply
Author
Message
  Topic Search Topic Search  Topic Options Topic Options
MrMcFu View Drop Down
Newbie
Newbie


Joined: 12 Jun 2007
Online Status: Offline
Posts: 3
  Quote MrMcFu Quote  Post ReplyReply Direct Link To This Post Topic: Error 2 Problem
    Posted: 20 Jun 2007 at 6:58pm
Hello,

I am running this product as part of an intraforest migration.  Occasionally, user profiles do not translate correctly during the move, so I need something on the client side to check and make sure the profiles are in fact moved.

The process works like this:

1.  User account migrated. (User is often logged in, computer locked etc since they tend to ignore emails from IT)

2.  Script run against user's computer gathering info such as last person logged in etc.

3.  Computer moved to other domain, user profiles translated etc.  Only those profiles not properly translated (ie, the user is logged on) are not copied.

4.  Computer reboots and auto-logs in with the local administrator.  Profwiz.exe runs with command line switches based on failed user profile translation (scraped from logfile).

**** weird part
5.  This is the log file of that transaction:

Finding Domain Controller for domain acme.org... Done.
Using Domain Controller: \\dc1.acme.org.
Binding to Active Directory... Done.
Getting Domain SID for user "JOHNSON@acme.og"... Done.
SID is S-1-5-21-372464671-2136817329-1307212239-14550
Checking for roaming profile...Done.
No roaming profile path set.
Setting Registry ACLs... Fails.
Unable to load Profile. Error 2.
The system cannot find the file specified.

6.  Machine reboots, user logs in, new profile created  "Doh!".

What I have done to figure out what the problem is:

Between steps 5 and 6, I run the tool from the command line manually, with the same settings as the script and get the same error.

After step 6, I log in as administrator, delete new profile, run the tool from the command line with the same settings as the script, same error.

Run the tool from the GUI, works like a charm!

After the profile is correctly setup, the script will strangely report success when I run it again.

So, my questions are these:

1.  What does error 2 mean?  How can I avoid it?
2.  Can I run the tool in GUI form, but capture what it would be IF I used a command line?

Bonus

1.  I want our helpdesk to use this tool - can they run it locally and change settings on a remote machine?
Back to Top
Support View Drop Down
Moderator Group
Moderator Group


Joined: 09 Nov 2006
Location: United Kingdom
Online Status: Offline
Posts: 1317
  Quote Support Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jun 2007 at 2:33pm
Hi,
 
Error 2 is what the log file says it is: "The system cannot find the file specified." The file in question is the user's ntuser.dat file; the file that holds the user's profile registry settings. For this not to work might indicate that there is a problem with the profile path stored in the registry under HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\ProfileList. However, given that you can run the GUI successfully, that is probably not the case; most likely, there is a command line issue.
 
You can run Profile Wizard on a remote a machine using a utility like Microsoft's psexec available here:
 
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.016 seconds.