ForensiT Homepage
Forum Home Forum Home > ForensiT Support > Domain Migration
  Active Topics Active Topics
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

Vista Upgrade Fails

 Post Reply Post Reply
Author
Message
  Topic Search Topic Search  Topic Options Topic Options
fishga View Drop Down
Newbie
Newbie


Joined: 20 Sep 2007
Location: United States
Online Status: Offline
Posts: 1
  Quote fishga Quote  Post ReplyReply Direct Link To This Post Topic: Vista Upgrade Fails
    Posted: 20 Sep 2007 at 9:10pm

I am using Profile wizard on Windows XP Professional, sharing a local profile with my domain account.  When I try to upgrade my desktop to Vista Enterprise, the upgrade fails.  The error log indicates that it cannot add mapping for that user profile.

If i attempt the upgrade from the domain account, the next time i try to login, it marks the local profile as "backup" and can no longer use that account with that profile.  If i attempt the upgrade from the local account, it marks the domain account profile as backup and can no longer use that account with that profile.
 
If I attempt the upgrade from the local administrator account with both accounts able to login (Profile states local), the upgrade fails.  If i attempt the upgrade from the local administrator account with the local account marked as backup, the upgrade succeeds.
 
Is there any way I can get the upgrade to work with both profiles working?
 
Thanks!
Back to Top
Support View Drop Down
Moderator Group
Moderator Group


Joined: 09 Nov 2006
Location: United Kingdom
Online Status: Offline
Posts: 1311
  Quote Support Quote  Post ReplyReply Direct Link To This Post Posted: 21 Sep 2007 at 2:00pm
Hi,
 
Interesting question!
 
The problem here is simply that Windows cannot load the same physical profile twice. When you upgrade from XP to Vista the upgrade program loads each profile in turn so that it can backup your settings. If you are logged in with an account that shares a profile and you run the upgrade, the upgrade program will not be able to load the profile for the other account because it is already loaded for you. As a result the upgrade fails as you say.
 
However, if you reboot your machine (to ensure no profiles are loaded) and logon with an account that does not have a shared profile the problem does not occur.
 
I understand that this was not your experience, but given your description of backup profiles being created, it does seem that the shared profile was loaded when you attempted the upgrade.
 
It is important to realize that once the upgrade to Vista has completed the profile will no longer be shared. Instead Vista creates a profile for each user account which is essentially a copy of the original shared profile. To share a profile again you will need to run User profile Wizard again. However, if you are looking to share profiles with Vista's Fast User Switching we would recommend you look at User Profile Manager.
 
 


Edited by Support - 21 Sep 2007 at 2:26pm
Back to Top
Carl Farrington View Drop Down
Newbie
Newbie


Joined: 05 Jul 2007
Location: United Kingdom
Online Status: Offline
Posts: 4
  Quote Carl Farrington Quote  Post ReplyReply Direct Link To This Post Posted: 19 Oct 2007 at 11:47am
Bugger. I was just about to post about this problem! Ah well, you beat me to it :)

http://groups.google.co.uk/group/microsoft.public.windows.vista.installation_setup/browse_thread/thread/9e38865e91c1fb8a/63dff17465884bfc?hl=en#63dff17465884bfc

:D


Edited by Carl Farrington - 19 Oct 2007 at 11:47am
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.031 seconds.