Print Page | Close Window

Problem With DefProf and Windows 8.1. Blank Tiles

Printed From: ForensiT
Category: ForensiT Support
Forum Name: Desktop Management
Forum Discription: User Profile Manager questions, suggestions, comments and bug reports
URL: http://forum.ForensiT.com/forum_posts.asp?TID=1091
Printed Date: 21 Sep 2019 at 4:06am


Topic: Problem With DefProf and Windows 8.1. Blank Tiles
Posted By: clivebuckwheat
Subject: Problem With DefProf and Windows 8.1. Blank Tiles
Date Posted: 21 Jul 2014 at 10:44pm
Hi

I am currently evaluating DefProf to see if it would be something useful for our Lab Image.I might have found a bug.

Here's how my process.

1. Login as Admininstrator, do my installations, and customizations such as start screen, pin tiles to task bar etc

2.  create another user called CopyProfile With Administrator rights.

3. Logoff as Administrator and reboot.

4. Login as User CopyProile,Run DefProf from an elevated cmd prompt with DefProf c:\Users\Administrator /y  

5. DefProf completes successfully, logoff as User CopyProfile and reboot.

6. I login as a brand new user that has never logged into the machine before, start screen is all ok pinned apps to task bar is ok, homepage settings all ok in all browsers.

THE PROBLEM IS AS FOLLOWS BELOW.

When I go to the start screen click the down arrow and go to Apps by Name screen, certain icons such as camera, store, skydrive, pc settings, and desktop are blank, they still work but they are blank and by blank I mean they have no picture in them. Most of the icons are ok otherwise. I can't figure it out.






Replies:
Posted By: Support
Date Posted: 22 Jul 2014 at 11:28am
This is not something we have ever seen.

We have noticed that occasionally there is a delay in updating live tiles, but we have not seen any blank tiles.


Posted By: clivebuckwheat
Date Posted: 22 Jul 2014 at 6:30pm
As you can see tiles are missing.




Posted By: clivebuckwheat
Date Posted: 24 Jul 2014 at 6:04pm
Is there anything I could do to resolve this issue?


Posted By: ray
Date Posted: 15 Aug 2014 at 11:57pm
try this in PowerShell (administrator)

powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register 'c:\program files\windowsapps\*\AppxManifest.xml

------
Ray


Posted By: clivebuckwheat
Date Posted: 18 Aug 2014 at 10:52am
Thanks Ray.

I Think you missed a quote?

shouldn't it be

powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register 'c:\program files\windowsapps\*\AppxManifest.xml'

Also do I run this before I run defprof or after?


Posted By: ray
Date Posted: 18 Aug 2014 at 3:30pm
yes! sorry ... missed the ' - I would run it afterwards and see how it behaves.


Posted By: clivebuckwheat
Date Posted: 24 Aug 2014 at 10:12am
Also I have noticed that using defprof the appstore always updates apps every new login if even updating apps is turned off via gpedit.msc is there a fix for that issue?






Posted By: clivebuckwheat
Date Posted: 24 Aug 2014 at 8:13pm
Sorry, I didn't see the error the first time when running the powershell script. It gives an error

powershell : Add-AppxPackage : A positional parameter cannot be found that accepts
argument
At C:\Windows\fixblanktiles.ps1:1 char:1
+ powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode
...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (Add-AppxPackage...cepts argument :Strin
   g) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError

'files\windowsapps\*\AppxManifest.xml'.
At line:1 char:1
+ Add-AppxPackage -DisableDevelopmentMode -Register c:\program
files\windowsapps\* ...


Posted By: BVrieling
Date Posted: 29 Sep 2014 at 8:48am
I have noticed the same problem ie. that the startscreen apps update with every new login (which is really bad for us because we use Deepfreeze, so we have "new logins" all the time).

At first I was not sure why the logins were so slow, but after I pressed CTRL-ALT-DELETE during the wait and then ESC, the screen showed what was going on (ie. the apps are updating).

It would be helpful to know if this is something which is on the radar to be addressed (ie. is it a problem, or is it just the way it is with DefProf?). Or, is this something User Profile Manager does better and we should use that?

Thanks,

...Bruce



Posted By: Support
Date Posted: 29 Sep 2014 at 10:11am
Please see page 21 of the http://www.forensit.com/Downloads/User%20Profile%20Manager%202.6%20User%20Guide.pdf - User Guide


Posted By: clivebuckwheat
Date Posted: 29 Sep 2014 at 10:38am
Thanks for the link, but is there no way to disable the updating completely?, I had to revert back to using sysprep's copy profile due to the updating of apps that defprof does.


Posted By: clivebuckwheat
Date Posted: 29 Sep 2014 at 10:42am
Hi
Bruce we use deep freeze as well, and had the same issue with the constant updating. So I decided to revert back to using sysprep's copy profile.

Defprof and User Profile are amazing products, that have a few quirks that I am hoping Forensit work out shortly, in regards to windows 8.x


Posted By: Support
Date Posted: 29 Sep 2014 at 12:41pm
If the Windows Store Apps are not updated they won't work. They are configured on a per user basis.

It would be easy for us to disable Store Apps updating. Do you not want to use them?


Posted By: BVrieling
Date Posted: 29 Sep 2014 at 2:19pm
We have no need for Windows Store Apps and would love to just have them removed / not updated / eradicated. The goal, for us, is to speed up the Windows login. We don't use the Windows apps, so if gutting them would help, the disable them.

I would be willing to beta test code for you too. ;)


Posted By: Support
Date Posted: 03 Oct 2014 at 6:37am
To disable Windows Store App updating on User Profile Manager please download the TID1091.zip file http://www.ForensiT.com/Downloads/Support/TID1091.zip - here .

Open the zip file and extract the upwpm2.exe file. Replace the existing upwpm2.exe file in C:\Windows on a Windows 8x machine where User Profile Manager is installed.

In the registry, you need to create a new DWORD (32-bit) value under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ForensiT\User Profile Manager called 'DisableAppxUpdate' (no quotes) and set the Value Data to 1.You can do this by importing the DisableAppxUpdate.reg file that is included in the TID1091.zip file. (These instructions assume you are running 64-bit Windows.)

This will prevent User Profile Manager from updating the Windows Store Apps. However, Windows might still install Windows Store Apps each time a user logs on to a machine for the first time. There are Group Policies you can set to prevent this from happening which you may want to investigate. See for example http://support2.microsoft.com/kb/2826659 - https://support2.microsoft.com/kb/2826659

Please let us know how you get on. If all is well we will update the User Profile Manager installer to include the updates.



Posted By: clivebuckwheat
Date Posted: 03 Oct 2014 at 9:25am
Will the following zip file work with defprof?


Posted By: Support
Date Posted: 13 Oct 2014 at 6:10am
We have now posted an update to DefProf (version 1.9) which enables you not to update Windows Store Apps.To do this, use the /NoAppx switch:

DefProf profilefoldername /NoAppx

As mentioned above, Windows will still install default apps for the new user logging on unless you take additional steps to stop it doing so.

If you want to prevent DefProf updating Windows Store Apps on a default profile you have already set with an older version of DefProf, delete the C:\Users\Default\AppData\Local\ForensiT folder.


Posted By: Sifulch
Date Posted: 14 Oct 2014 at 6:43pm
Hi,

I'm having the same issues, I'm just wondering where the 1.9 version of Defprof is as the only one I can download is 1.8?


Posted By: Support
Date Posted: 15 Oct 2014 at 12:40am
It is in the http://www.forensit.com/support-downloads.html - usual place .Where are you getting it from?


Posted By: Sifulch
Date Posted: 15 Oct 2014 at 9:04pm
That's where I downloaded it from, I'm just going by the properties as shown.




Posted By: Support
Date Posted: 16 Oct 2014 at 4:19am
The version on our website is 1.9. May be check whether the page is being cached by your browser or any proxy server.


Posted By: Sifulch
Date Posted: 16 Oct 2014 at 8:30pm
No problems, will try from home seeing how enterprise networks can be a pain at times.



Print Page | Close Window