Print Page | Close Window

Defprof 1.11 on Windows 2012 R2

Printed From: ForensiT
Category: ForensiT Support
Forum Name: Desktop Management
Forum Discription: User Profile Manager questions, suggestions, comments and bug reports
URL: http://forum.ForensiT.com/forum_posts.asp?TID=1331
Printed Date: 28 Sep 2020 at 7:36am


Topic: Defprof 1.11 on Windows 2012 R2
Posted By: BenH
Subject: Defprof 1.11 on Windows 2012 R2
Date Posted: 13 Apr 2016 at 2:25pm
I'm unable to get DefProf to work properly on Windows 2012 R2.

Steps taken:
- Customize Administrator profile as required
- Create "copy" user with admin privileges
- Login as copy user and use "defprof c:\users\Administrator"

I have tried multiple combinations of command line parameters and one of three things happens:

- If I use the standard syntax "defprof path" and choose NOT to install the service, then when a new user logs in they get a crash on upwpm2 during the store app configuration.

- If I use the standard syntax "defprox path" and choose to install the service, then when a new user logs in the store app configuration runs properly (no crash), but multiple tiles in the start menu are empty and the file location is still pointing to the c:\users\administrator location (hence that is why they are empty, user has no permissions to access this location).

- If I use the syntax "defprof path /noappx" (not prompted for the services), then when a new user logs in no store configuration runs AND the icons are still empty as mentioned above.

I must admit I'm not too versed in how the store apps work relative to a new profile and what exactly needs to be run for each user. I believe what I want to do is use the /noappx parameter to skip the store apps (though I don't know what negative this might have).

Ideally, I don't want to have an extra service running on the system either. Regardless though, I can't get this to work properly in any scenario.

Advice?



Replies:
Posted By: BenH
Date Posted: 13 Apr 2016 at 3:57pm
Clarification on what I mean by "blank icons"

The icons aren't actually blank, they are an icon of a white page with the upper left corner bent.

Again, I'm sure these show this way because the path on these continues to point to the c:\users\Administrator profile for these objects, which another user won't have access to.

On further testing, it appears now that whatever method I try I am always getting these icon issues. I even tried to customize a new profile (non built-in Administrator user) and copy this one...but the same issues occur.

I backed up my original Default Profile, and when I copy it back to c:\users\Default, everything works fine again...so I'm not sure what is going on.


Posted By: filovitch
Date Posted: 09 May 2016 at 7:57am
Hi,

I have the exact same problem. I confirm it is because the paths of the programs are the paths for the Administrator user.

http://www.hostingpics.net/viewer.php?id=410043421.png">

Strangely, if I logoff/login the new user, the paths are corrected.

Is anyone have a solution?

PS: I use the last version of Defprof (1.11)



Print Page | Close Window