Print Page | Close Window

Local to Azure AD does not work.. in 3.11

Printed From: ForensiT
Category: ForensiT Support
Forum Name: Domain Migration
Forum Discription: User Profile Wizard questions, suggestions, comments and bug reports
Printed Date: 04 Aug 2020 at 2:20pm

Topic: Local to Azure AD does not work.. in 3.11
Posted By: bobobo
Subject: Local to Azure AD does not work.. in 3.11
Date Posted: 21 Jul 2016 at 7:32pm
I know this was an added feature in 3.11 but once you get to the Azure AD profile screen, select your Azure AD name and type in the email address of AAD account, the "Next" button stays greyed out no matter what you do, you cannot go further.

Bug I guess?

Posted By: Support
Date Posted: 22 Jul 2016 at 4:48am
We don't see this at all. What build of Profwiz.exe are you using?

Posted By: bobobo
Date Posted: 22 Jul 2016 at 9:12am
Using version 3.11 the free one. Unless that is a paid only feature.

The azure ad company shows up automatically as stated as a read-only box and when I goto the next box on the screen , I get prompted to "enter a work or school email"

Once the email is entered, the next box remains grey. The computer is AzureAD joined, I logged into the AzureAD profile in advanced and I tried running profwiz from the azuread account, local account, and another local account which wouldn't be part of the migration.

Ran as administrator, but I don't think that makes a difference.

Posted By: Support
Date Posted: 22 Jul 2016 at 10:37am
You're right, it's a bug

The problem (we think) is that there is a comma in your Azure AD organization name. Profwiz.exe is treating the Azure AD organization name as a domain name - you can't have commas in a domain name, so it is rejecting it as invalid and won't let you go any further.

We'll have to fix it...

Posted By: bobobo
Date Posted: 22 Jul 2016 at 5:47pm
Thanks for the quick update. I just wanted to make sure I wasn't going crazy.

I think I might be able to change the azure ad name to remove the comma. I don't think there would be any ramifications.

Posted By: Meaaa
Date Posted: 17 Aug 2016 at 12:39pm

I am evaluating Profile Wizard. I am trying to migrate a local account to a Azure AD account. I downloaded the free version 3.11.

The machine is joined to azure, I have logged in as the azure user I want to migrate to, run Profile Wizard and it responds per the manual where it shows the AzureAD in the domain box and then when I enter the azure domain user email address it Says - Cannot find domain. Make sure user is logged into machine first. (Which I Have)

In the first screen where you select the accounts to migrate, I can see the local accounts and the Azure accounts.

What am I doing wrong ? This would be a terrific time saver if it works.

Is this only available in Pro or Corporate ?


Posted By: Support
Date Posted: 18 Aug 2016 at 3:14am
Are you sure it says it cannot find the domain? Can you send a screenshot to - ? Thanks.

Posted By: Stratocent
Date Posted: 21 Feb 2017 at 8:58pm
Using 3.12, ran into the comma issue again - the machine was both workplace joined and AzureAD joined to the same domain, and there was a comma in the AzureAD company name (not the domain). When forensit polls the AzureAD directory, it doesn't grab the domain name, it grabs the title of the domain, which could be anything, except it will not allow the "next" button if there is a comma in the domain box. Going back to AzureAD, removing the workplace join, and re-naming the domain title fixed it.

Posted By: TheVigil7
Date Posted: 07 Mar 2018 at 1:27pm
Was there ever a resolution to the 'next' button being grayed out when converting a local AD account to AAD? I have the exact same issue with computers in one network. Have never had this issue with any others, cannot figure out what is unique about these computers specifically.

Print Page | Close Window