ForensiT Homepage
Forum Home Forum Home > ForensiT Support > Desktop Management
  New Posts New Posts RSS Feed - DefProf / Windows Defender
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

DefProf / Windows Defender

 Post Reply Post Reply
Author
Message
WMDracutus View Drop Down
Newbie
Newbie


Joined: 18 Aug 2021
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote WMDracutus Quote  Post ReplyReply Direct Link To This Post Topic: DefProf / Windows Defender
    Posted: 18 Aug 2021 at 2:27pm
Greetings,

I have created a defaut profule using DefProf 1.10. Windows 10 version is 21h1. 


When ever i copy the default profile to a new computer and create a new users, everything works fine except i get the following error regarding Windows Security.

"You'll need a new app to open this windowsdefender"



It does not appear in the start menu, but does in settings, click on it there in settings and the icon in the task bar brings up this error


Ive done:

- SFC /Scannow

- Add-AppxPackage -Register -DisableDevelopmentMode "C:\Windows\SystemApps\Microsoft.Windows.SecHealthUI_cw5n1h2txyewy\AppXManifest.xml"

- WSReset

- Clean install

- Cortana work around

- Editing the registry to turn it on.

- Run Command upwpm2 -force

- as well as the different options when running defprof, ie installappx / delete / noappx


Is there anything else i can try, or is there another way that i should be moving the defauilt profile?

Right now i am just creating a temp user, and the copy & paste the default user on the new computer and then creating the new users.


Cheers


Edited by WMDracutus - 18 Aug 2021 at 2:29pm
Back to Top
WMDracutus View Drop Down
Newbie
Newbie


Joined: 18 Aug 2021
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote WMDracutus Quote  Post ReplyReply Direct Link To This Post Posted: 31 Aug 2021 at 5:07pm
Hi Peeps, 

Just providing an update, I have resolved this issue for anyone who else has this same issue.

I resolved this by applying two fixes.


**Go to c:\program files in explorer
**Change explorers settings temporarily to show hidden files AND system files
**Right click on now viewable WindowsApps directory and we are going into security.
**Take ownership of all the files

I found that you needed to be signed into an administrator account

After this process is finished I then ran the add-AppxPackage powershell command.

I completed the whole process using command prompt via a batch file.

takeown /F "C:\Program Files\WindowsApps" /A /R /D Y
icacls "C:\Program Files\WindowsApps" /grant "InsertUserNameHere":F /t /c /q
powershell Add-AppxPackage -Register -DisableDevelopmentMode "C:\Windows\SystemApps\Microsoft.Windows.SecHealthUI_cw5n1h2txyewy\AppXManifest.xml"

After I did this, Windows Security appeared in the Start Menu and I was then able to access Windows Security.

Hope this helps someone.

Also im not sure if this issue is a by product of the defprof process and a fix can be introduced into the next version?

Cheers!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.03
Copyright ©2001-2019 Web Wiz Ltd.

This page was generated in 0.018 seconds.