ForensiT Homepage
Forum Home Forum Home > ForensiT Support > Move Computer
  New Posts New Posts RSS Feed - ms-phone-api popup after using Transwiz
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

ms-phone-api popup after using Transwiz

 Post Reply Post Reply
Author
Message
jackr View Drop Down
Newbie
Newbie


Joined: 26 Mar 2021
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote jackr Quote  Post ReplyReply Direct Link To This Post Topic: ms-phone-api popup after using Transwiz
    Posted: 26 Mar 2021 at 5:18pm
Hi,
Recently used Transwiz to migrate a handful of user profiles from desktop computers running Windows 10 to a terminal server running Server 2019. Everything went great with one exception: We are getting the "How do you want to open this file? ms-phone-api" popup upon login on some accounts. 

My guess is that this is somehow related to the YourPhone Win10 app not being present on the terminal server, but I cannot find what is calling this. I have checked all startups in Autoruns and none seem related. I have also run Process Monitor on a seperate Windows 10 machine to see which registry keys are modified while enabling/disabling YourPhone in the task manager. These keys are at HKEY_USERS\SID_Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData\Microsoft.YourPhone_8wekyb3d8bbwe\YourPhone
The keys were already all disabled for all users on the terminal server.

Any ideas?
Back to Top
asexton View Drop Down
Newbie
Newbie


Joined: 29 Jun 2021
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote asexton Quote  Post ReplyReply Direct Link To This Post Posted: 29 Jun 2021 at 2:33am
Hi Jackr,

Did you ever find a fix, I'm pretty desperate. We did not use Transwiz it was caused by roaming profile from Win 10 to Server 2019.

Thanks,

Ashley
Back to Top
Cheesecake View Drop Down
Newbie
Newbie


Joined: 17 Nov 2021
Status: Offline
Points: 6
Post Options Post Options   Thanks (1) Thanks(1)   Quote Cheesecake Quote  Post ReplyReply Direct Link To This Post Posted: 18 Nov 2021 at 7:40am
Hi,

I've created this account for the sole purpose of helping you out, I hope you read this, since that problem drove me crazy!

The problem started, after having our employees logging into our terminal servers with roaming and folder redirection enabled.

I used processmonitor for all further investigation:

I found, that on login, apparantly the iexplorer on our server 2019 machines tried to call a website with a protocol value of "ms-phone-api://event/locked" as well as "ms-phone-api://event/unlocked".

This lead explorer.exe to lookup the associated protocol handler, which it couldn't find and then asked his friend openwith.exe to find the associated protocol handler, which it also couldn't find, which as a result asked the USER for help resulting in said error message.


tl;dr
[!SOLUTION!]
Create the following registry key structure, leave all keys empty:

Computer\HKEY_CLASSES_ROOT\ms-phone-api\shell\open\command

### REG FILE ### COPY CONTENTS TO A FILE AND SAVE IT AS .REG

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\ms-phone-api]
"URL Protocol"=""
@=""

[HKEY_CLASSES_ROOT\ms-phone-api\shell]

[HKEY_CLASSES_ROOT\ms-phone-api\shell\open]

[HKEY_CLASSES_ROOT\ms-phone-api\shell\open\command]
@=""
Back to Top
asexton View Drop Down
Newbie
Newbie


Joined: 29 Jun 2021
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote asexton Quote  Post ReplyReply Direct Link To This Post Posted: 19 Nov 2021 at 1:55am
Hello cheesecake,

That did it!
Can I offer my sincere thanks, this issue has been ongoing for almost 6 months (thankfully only to 3 of my users) and I was one step off rebuilding their Roaming profiles from scratch.

I owe you a beer or 5

Thank you

Ashley
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.03
Copyright ©2001-2019 Web Wiz Ltd.

This page was generated in 0.016 seconds.