Print Page | Close Window

Store apps immediately close themselves

Printed From: ForensiT
Category: ForensiT Support
Forum Name: Move Computer
Forum Description: User Profile Transfer Wizard questions, suggestions, comments and bug reports
Printed Date: 06 May 2021 at 7:33pm
Software Version: Web Wiz Forums 12.03 -

Topic: Store apps immediately close themselves
Posted By: cfrankb
Subject: Store apps immediately close themselves
Date Posted: 25 Apr 2019 at 5:45pm
Upon recommendation, I used "User Profile Wizard 3.16" on four PCs (Win10 Pro Build 1809, except 1 still on 1803).
I logged into my local administrator account to copy a different local administrator account to a new Azure AD account. Everything seemed to work successfully. But the installed-by-default Microsoft Store apps, such as the Calculator, Photos, and Snip & Sketch, all immediately flash open and then close (see example log below).

I can log into the PCs with a different Azure AD account and those apps work fine, so I don't think it's an O365 tenant or Azure AD issue.

I've tried a few ways of removing an affected profile (System Properties – Advanced – User Profiles, C:\Users\, even deleting Windows Registry entries), but the apps still close for the Azure AD users for which I used the User Profile Wizard.

On another PC I tried Disconnecting from Azure AD, rebooting, Connecting again, but now whenever I sign-in with the PC's primary Azure AD, it drops me into a new C:\Users\Temp profile warning me nothing will be saved and that sometimes the login issue can be resolved by logging in again, but it doesn't resolve the issue.

What's the quickest way to get each PC to think I'm logging in to its primary Azure AD account for the first time so those apps work?

Log Name:      Application
Source:        Application Error
Date:          4/25/2019 8:05:14 AM
Event ID:      1000
Task Category: (100)
Level:        Error
Keywords:      Classic
User:          N/A
Computer:      DESKTOP-RCB0NA6
Faulting application name: Calculator.exe, version: 10.1902.42.0, time stamp: 0x5c95693d
Faulting module name: Windows.UI.Xaml.dll, version: 10.0.17763.404, time stamp: 0x155de37a
Exception code: 0xc000027b
Fault offset: 0x0000000000707842
Faulting process id: 0x303c
Faulting application start time: 0x01d4fb7849602ed5
Faulting application path: C:\Program Files\WindowsApps\Microsoft.WindowsCalculator_10.1902.42.0_x64__8wekyb3d8bbwe\Calculator.exe
Faulting module path: C:\Windows\System32\Windows.UI.Xaml.dll
Report Id: 81a3f129-e66a-42b1-8da8-69103d6064ed
Faulting package full name: Microsoft.WindowsCalculator_10.1902.42.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App
Event Xml:
<Event xmlns="">
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <TimeCreated SystemTime="2019-04-25T15:05:14.778414600Z" />
    <Security />
    <Data>C:\Program Files\WindowsApps\Microsoft.WindowsCalculator_10.1902.42.0_x64__8wekyb3d8bbwe\Calculator.exe</Data>

Posted By: Support
Date Posted: 26 Apr 2019 at 4:48am
Many thanks for the information.

There are two things which stand out. Firstly, you still have a problem if the profile is deleted, which indicates that whatever is causing this issue exists outside of the profile that was migrated. Secondly, if you migrated to an Azure AD account, you must have already signed-in with that account before migrating the profile. (As that is the only way to migrate a profile to an Azure AD account with User Profile Wizard.)

You say that you wanted to “copy a different local administrator account to a new Azure AD account”. Do you mean copy? By default User Profile Wizard does not move, copy or delete any data. Instead it configures the existing profile “in place” so that it can be used by the user’s new account. Copying a profile is a very different operation and is an option of the Professional and Corporate Editions only. Please let us know what you did.

We will run some new tests based on a user having already signed-in.

Posted By: cfrankb
Date Posted: 26 Apr 2019 at 1:17pm
This morning I started a fresh test on another Win10 Pro 1809. I didn't want to mess-up the user on vacation this week, so added two local admin accounts: frank and fb. I only stayed logged in to one account at a time; no Switching. The Calculator stayed open in both frank and fb. I used profile fb to join Azure AD for my own address (say and the calculator worked after signing into it. Then I signed out and logged into fb, ran the User Profile Wizard to select profile frank, hit Next and saw my company name listed in the drop-down under "Enter the domain, or select the local computer name", entered my Azure AD email address under "Enter the account name", and checked "Set as default logon". When the Wizard completed successfully, the PC restarted and I logged into my Azure AD email address, and the Calculator closed, as I experienced on 4 other PCs, one of which was Build 1803. I logged out and into that and fortunately the Calculator stays open.

By "copy" I think I meant migrate based on what I recall the Wizard stating near the end: Migration complete (IIRC). So maybe more of a move than a copy or an "in place" configure or conversion? I thought it was a copy since under C:\users I have fb, frank, and the new fbernard.

The PCs all have the latest Webroot SecureAnywhere Endpoint Protection, and Windows Defender is set to periodic scanning. Neither have alerted me of issues.

BTW, I found this interesting last night: "2018-10-09: Delprof2 has issues with UWP apps on Windows 10. Why? Windows 10 stores per-user settings in per-machine database files that are exclusively locked (almost?) all of the time. I consider this a design flaw on the part of Microsoft and I am not going to waste my time trying to work around that."

Posted By: cfrankb
Date Posted: 09 May 2019 at 11:07am
Is there a fix in the works?

Posted By: jeffhesser
Date Posted: 31 May 2019 at 11:31am
I've also seen this a few times and had no luck fixing it.

Posted By: jeffhesser
Date Posted: 31 May 2019 at 2:21pm
I actually think I found a fix for this. This powershell line run as the user (as an admin) is my new favorite fix - Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

Posted By: cfrankb
Date Posted: 03 Jun 2019 at 12:15pm
Thank you.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.03 -
Copyright ©2001-2019 Web Wiz Ltd. -