ForensiT Homepage
Forum Home Forum Home > ForensiT Support > Desktop Management
  New Posts New Posts RSS Feed - DefProf - The Profile is In Use
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

DefProf - The Profile is In Use

 Post Reply Post Reply
Author
Message
TorontoUser View Drop Down
Newbie
Newbie


Joined: 16 Jul 2020
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote TorontoUser Quote  Post ReplyReply Direct Link To This Post Topic: DefProf - The Profile is In Use
    Posted: 16 Jul 2020 at 1:10pm
I have two machines running Windows 10, Build 2004. I created them with accounts that have administrative rights; let's call those accounts Installer.

A few days ago I ran
c:\Defprof Installer
on one of them. Worked brilliantly.

Today I built the second machine and ran
c:\Defprof Installer
and got the message:
"The Profile is in use. The user must sign off before running Defprof".

Others have had this problem, for example:
http://forum.forensit.com/forum_posts.asp?TID=1905
http://forum.forensit.com/forum_posts.asp?TID=1374

I also tried, in an administrative level command prompt:
runas /noprofile /user:Installer "C:\defprof Installer"

that gave me:
"Attempting to start c:\defprof Installer as user "THISPC\Installer"...

and just in case I also tried,
runas /noprofile /user:Administrater "C:\defprof Installer"

Any ideas would really, really be appreciated!
Back to Top
TorontoUser View Drop Down
Newbie
Newbie


Joined: 16 Jul 2020
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote TorontoUser Quote  Post ReplyReply Direct Link To This Post Posted: 16 Jul 2020 at 3:47pm
I have solved my own problem, although I'm not clear on the cause. Here's what I did, for use by others.
First, I rebooted from the command window using:
shutdown.exe -r -f -t 0

This acutally did something for me - after rebooting I tried again and got a message about the Forensit service updating store apps. But then I once again got the "profile in use error."

I had made a Veeam Agent backup of the computer immediately prior to trying DefProf. Fortunately. So I restored it. Then I ran Defprof and it worked fine.

The system configurations at the time when DefProf was refusing to function, and the time when it did function, were identical.

It seems reasonable to assume that DefProf was correct and the user profile was actually somehow in use, although I tried rebooting several times and logging back in with a different profile. If you also have this problem, you might try restoring a backup and running DefProf on it.

Bear in mind that I'm not an IT consultant. I just sometimes have to perform this role at our own, very small firm.
Back to Top
Support View Drop Down
Moderator Group
Moderator Group


Joined: 09 Nov 2006
Location: United Kingdom
Status: Offline
Points: 1401
Post Options Post Options   Thanks (0) Thanks(0)   Quote Support Quote  Post ReplyReply Direct Link To This Post Posted: 17 Jul 2020 at 3:08am
Thank you for your feedback. We have observed that Windows 10 will load profiles in the background (without a user being signed-in) to do updates, etc.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.03
Copyright ©2001-2019 Web Wiz Ltd.

This page was generated in 0.078 seconds.